Z nami uczy się już 7407 osób. Czekamy na Ciebie

Strona główna » Blog » Wyszukiwanie tekstu od końca

Wyszukiwanie tekstu od końca

Załóżmy, że potrzebujesz znaleźć pewien ciąg znaków w tekście, a właściwie jego pozycję. W takim razie pewnie sięgniesz od razu po funkcję ZNAJDŹ.

Chyba najczęstszym przykładem w takiej sytuacji jest to, że chcesz wyciągnąć pierwszy wyraz, czyli potrzebujesz znaleźć pozycję pierwszej spacji. W takiej sytuacji funkcja ZNAJDŹ sprawdza się idealnie.

Załóżmy, że masz prosty tekst:
Chrząszcz brzmi w trzcinie w Szczebrzeszynie

Wystarczy, że napiszesz taką prostą funkcję, żeby znaleźć spację:
=ZNAJDŹ(” „;A1)

tekst01

Teraz zostaje jej wynik połączyć z funkcją LEWY, by wyciągnąć pierwszy wyraz. Musisz tylko pamiętać, by od pozycji pierwszej spacji odjąć jedynkę, żeby ta spacja również nie znalazła się w tekście, który wyciągasz.

=LEWY(A1;ZNAJDŹ(” „; A1)-1)

Ta część tylko dla członków iExcel.pl
Wystarczy zarejestrować się za darmo by odblokować treść.

tekst05

Czyli już udało nam się uzyskać ostatni wyraz w tekście.

Teraz ewentualnie przydałoby się napisać mechanizm chroniący w sytuacji, gdyby szukany tekst nie został odnaleziony. Można to osiągnąć np.: sprawdzając najpierw jaki wynik zwraca funkcja ZNAJDŹ. Ponieważ, gdy nie znajdziesz szukanego tekstu zwraca błąd #ARG!. Czyli możesz dokonać sprawdzenia logicznego – jeżeli wartość zwracana przez funkcję ZNAJDŹ daje błąd (=CZY.BŁ(ZNAJDŹ(” „;A1)) to wtedy niech będzie zwracany cały przeszukiwany tekst. W przeciwnej sytuacji wynik powyższej formuły. Czyli da się to łatwo opakować w funkcję JEŻELI i cała formuła będzie wyglądać tak:

=JEŻELI(CZY.BŁ(ZNAJDŹ(” „; A1));A1;PRAWY(A1;DŁ(A1)-ZNAJDŹ(„~”;PODSTAW(A1;” „;”~”;DŁ(A1)-DŁ(PODSTAW(A1;” „;””))))))

tekst06

W sytuacji, gdy szukasz innego tekstu niż spacja wystarczy podmienić jej wartości na dowolny inny ciąg tekstowy. Dla ułatwienia w poniższej formule został dodany czerwony X jako miejsce, w które powinieneś wstawić szukany przez Ciebie ciąg tekstowy.

=JEŻELI(CZY.BŁ(ZNAJDŹ(„X”; A1));A1;PRAWY(A1;DŁ(A1)-ZNAJDŹ(„~”;PODSTAW(A1;”X”;”~”;DŁ(A1)-DŁ(PODSTAW(A1;”X”;””))))))

Pamiętaj też, że tyldę ~ też możesz zamienić na inny znak/ciąg tekstowy.


Film i materiały do lekcji mogą oglądać tylko zalogowani użytkownicy. Nie masz konta?
Zarejestruj się za darmo lub dowiedz się więcej


Lekcja-1,99zł
  • Dostęp do wybranej listy

lub dostęp do całego serwisu przez

Rok-49zł
  • Dostęp do ponad 200 lekcji
  • Możliwość zdobycia certyfikatu
  • Udział w konferencjach on-line
  • Liczne pliki, ćwiczenia i testy
  • Co tydzień nowa lekcja
Firmy szkolące się na platformie www.iExcel.pl
CLOSE
CLOSE
Przeczytaj poprzedni wpis:
Kryteria05
Wyszukiwanie po kilku kryteriach

Chcesz wyszukać wartość po dwóch lub więcej kryteriach w zbiorze danych w Excelu? Jak w większości przypadków w Excelu są...

Zamknij